Sep 262014
 

The Shellshock bug affects the Bash shell.

Though Perl it self is not directly affected, some web servers (such as Apache) that run Perl are, additional if Perl shells out: system(), backticks, qx etc, that may then instantiate bash which would be a potential attack vector.

Perl tricks has a good write up.

Your best protection is upgrading Bash on your operating system as soon as patches are available, or switching all accounts to an alternative shell (such as ‘sh’, or ‘zsh’) until there is.

Be aware there were 2 releases of bash to fix this, as the first was not complete.

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)